Por qué debes actualizar PHP a la versión 7.1 o superior YA

  • noviembre 17, 2020

No sé si sabe que PHP se ha desarrollado con bastante fuerza últimamente. Esto significa, entre otras cosas, que debe actualizar WordPress y actualizarlo para garantizar un sitio seguro.

Pero no solo deberías saber cómo, cuándo y por qué actualiza PHP, pero también qué hacer si hay un problema de compatibilidad, algo relativamente fácil sucederá por las razones que leerá a continuación.

¿Quieres saber cómo evitar dolores de cabeza al actualizar y qué debes comprobar si cambias la versión PHP de tu sitio a una superior?

Quédate conmigo porque te voy a contar todo lo que necesitas saber y por qué DEBE cambiar a PHP 7.1 o superior AHORA.

¿Qué es PHP?

PHP es el código de idioma utilizado por WordPress, complementos y temas. Y como todo el código y el software existentes, mejora con el tiempo, lanzar nuevas versiones optimizadas y el soporte ya no está disponible para los más obsoletos.

Por lo tanto, trabajar con una versión anterior no compatible representa un riesgo para su sitio:

  • Errores
  • Brechas de seguridad
  • Fallas

Está bien, pero …

¿Dónde está el verdadero valor de actualizar la versión de PHP?

Aquí llegamos al meollo del asunto.

La mayoría de los emprendedores y negocios digitales todavía tienen la versión 5.x de PHP. Y. el soporte para cualquier versión por debajo de 5.6 ya ha sido eliminado. Y a 5.6 desaparecerá el 31 de diciembre de 2018.

Por otro lado, la versión PHP 7.0 se lanzó desde diciembre de 2015 y el 3 de diciembre de 2018 ya no recibirá soporte y seguridad activos.

Perder el soporte de la versión PHP significa que cualquiera que use la versión anterior tendrá un enorme agujero de seguridad en su sitio si no se actualiza.

¿Qué pasa con las versiones de PHP 7.1 y 7.2?

Bueno, el soporte para ellos todavía está activo, incluso considerando que PHP 7.3 ya está disponible.

Si estás interesado aquí puede ver las fechas de soporte para cada versión de PHP.

¿Qué significa todo esto?

Bueno, necesita actualizar a una de estas versiones más modernas de PHP antes del 31 de diciembre de 2018.

Verifique y cambie la versión de PHP

Si eres de los que todavía usa la versión 5.x, estás interesado en revisar tu sitio web para asegurarte de que con la versión 7.x no tendrás problemas de compatibilidad.

Tenga en cuenta que el salto de 5.xa 7.x es enorme. La transición de 7.xa otro 7.x no es un cambio tan grande, por lo que no es necesario verificar la compatibilidad, como es el caso a partir de la versión 5.x.

El código PHP lo proporciona su proveedor de alojamiento porque se utiliza para proporcionarle ciertas funciones en el servicio. Entonces necesita actualizar su versión de PHP desde su cuenta de alojamiento.

Y la forma más fácil de hacer eso a través de cPanel.

Cambiar la versión de PHP de Raiola Networks

Si su proveedor de alojamiento es Raiola para cambiar la versión de PHP, solo necesita ir a cPanel, seleccionar la opción «Versión de PHP» y hacer clic en.

Una vez dentro, en el menú desplegable que ves arriba, seleccione la versión deseada y haga clic en «Establecer como actual».

Cambiar la versión de PHP en Webempresa

Para hacer esto con Webempresa, los pasos son muy similares.

Vaya a su cuenta de cPanel y seleccione la opción «Configurar PHP».

Una vez dentro, tu eliges la última versión ¡y listo!

cambiar la versión de PHP a webempresa

Si prefiere ver el video paso a paso, haga clic en «Reproducir». 🙂

Cambiar la versión de PHP puede resultar confuso

Dado que muchas personas han estado trabajando con la versión 5.x durante años, nunca tuve que preocuparme por actualizar PHP. Y si eres uno de ellos, es muy posible que lo que te estoy contando suene un poco a chino.

La mayoría de los complementos siguen siendo compatibles con la versión 5.6. Pero esto, como hemos dicho, pronto dejará de serlo.

WordPress 5.0 solo se prueba en PHP 7.3. Esto significa que no hay garantía de que sea compatible con versiones anteriores. Y no hay garantía de que sus complementos sean compatibles con PHP 7.3.

De hecho, ahora hay algunos proveedores que ni siquiera ofrecen la versión 7.3 de PHP debido a lo nuevo que es y al riesgo de incompatibilidad con los complementos …

Los complementos son un problema real

Ahora todos los desarrolladores que han creado complementos para WordPress 5.0 tienen una solución difícil.

O modifican los complementos para que sean compatibles con PHP 7.3 y Gutenberg … o si les resulta demasiado trabajo, tal vez sea mejor para ellos tirarlos.

Y tenga cuidado, esta segunda opción no parece que vaya a ser residual: algunos complementos de pago ya han anunciado que con la llegada de WordPress 5.0 se desactivarán.

Mientras tanto, otros desarrolladores probarán sus complementos. solo con la última versión de PHP, y no intentarán hacerlo compatible con versiones anteriores.

Y este es el truco.

Durante 2019, tendremos plugins en varios estados compatibles con PHP.

Por lo tanto, si está utilizando PHP 7.1, es posible que deba actualizar a 7.3 para que funcione un complemento en particular. Y esto puede dar lugar a incompatibilidades con otro complemento que aún no se ha adaptado a esta versión.

Te das cuenta de lo loco que es esto hernia?

¿Cómo puede saber qué versión de PHP necesitan sus complementos?

Buena pregunta.

En el momento, No existe una lista en la que podamos ver la versión mínima de PHP que requiere cada complemento en el repositorio de WordPress. Entonces, la única forma realmente confiable de averiguarlo es … probando en línea.

Y eso no es una buena noticia.

Entre otras cosas, porque puede tener problemas con Internet al actualizar el complemento. Este error o conflicto puede manifestarse con síntomas como:

  • Nuevo mensaje de error.
  • Pérdida de alguna funcionalidad.
  • Incluso el hecho de que la pantalla es toda blanca (y el color permanece).

Ozu, que desastre miyarma!!

La buena noticia: esta tenemos un complemento que hace la vida más fácil y con el que podrás saber si tu WordPress y tus plugins son compatibles con la versión 7.x. El complemento está ahí Comprobación de compatibilidad con PHP.

Si el resultado muestra que el complemento que está analizando NO es compatible con la versión 7.x, debe cambiarlo o pedirle al desarrollador que busque actualizaciones.

Y si no sabes si es compatible o no, tendrás que retroceder, solicitar una actualización al desarrollador … o cambiar el complemento como resultado.

¿Qué versión de PHP necesita utilizar en línea?

Nuevamente, una buena pregunta. 😀

Y la respuesta: depende.

Cada sitio web es diferente: tiene necesidades específicas y utiliza temas y complementos específicos.

Por lo tanto, lo que funciona en un caso puede no funcionar en otro.

Mi consejo: pruebe la última versión que pueda y vea qué sucede.

¿Y si compartimos casos de incompatibilidad?

La actualización a la última versión de PHP es algo que nos afecta a todos, por lo que es importante evitar problemas de seguridad. ¿Qué piensas cuando nos ayudamos unos a otros?

yo sugiero Si encuentra errores o problemas por incompatibilidades, háganoslo saber en los comentarios. Desde «Hormigas en la Nube» intentaremos ayudarte y la información servirá a otros lectores.

¡Te espero en los comentarios!

Y si está loco por las actualizaciones, eche un vistazo al servicio de soporte de Sherpa y elimine los dolores de cabeza que le brinda la parte técnica de su sitio.

No Comments Found